project reality header
Go Back   Project Reality Forums > PR:BF2 Mod Forums > PR:BF2 Bugs
23 Jul 2019, 00:00:00 (PRT)
Register Developer Blogs Project Reality Members List Search Today's Posts Mark Forums Read
PR:BF2 Bugs If you find a bug within PR:BF2 (including PRSP), please report it here.

Reply
 
Thread Tools Display Modes
Old 2015-06-03, 17:15   #1
[TSS]FrankDaTank1218
Unhappy Cannot play more than 15 minutes before disconnecting, in ANY server.

Game disconnects right around the 15 minute mark in every server. I've played before standalone (last time it was one of the later .9 builds) and don't recall this happening.

Maybe thought of port forwarding but after googling I found that NOWHERE are the port numbers posted.

This disconnecting just happens to often be around first contact with the enemy (not always, just around 15 minutes is bad timing) and is EXTREMELY infuriating, as of right now, my game is unplayable. Any help would be appreciated.

Additional details:

-Using an ASUS RT-AC66R router. Works fine under high loads at my house, even when doing stuff like hosting private Arma 3 servers while 3 other people's phones and computers are on the network.

-Using a Comcast modem with a 100 megabit connection, in reality it hovers between 85 megabits to 98 megabits. Again, no issues in other games.

-I am running from a hardline connection, not wifi.

-I have Windows 7

-I am not terribly familiar with Mumble, perhaps that is where the issue lies?
[TSS]FrankDaTank1218 is offline Reply With Quote
Old 2015-06-07, 20:46   #2
T0P1K

T0P1K's Avatar
Default Re: Cannot play more than 15 minutes before disconnecting, in ANY server.

"-Using a Comcast modem with a 100 megabit connection, in reality it hovers between 85 megabits to 98 megabits. Again, no issues in other games."

I also have the same problem as you and i have a sneaking suspicion it's the modem who is the culprit. I'll be buying a new one (changing out the standard Comcast modem) soon because i also have problems with streaming other video services. I'll let you know if this solved the problem or not.
T0P1K is offline Reply With Quote
Old 2015-06-07, 22:39   #3
Switchback
Default Re: Cannot play more than 15 minutes before disconnecting, in ANY server.

Few Suggestions/things to try:

- If your cable box is next to the router, try bypassing the ASUS router and connect directly to the modem. This will rule out any problems with the ASUS tech.

- Wireshark inbound and outbound connections on your ethernet line, see if there's a break in communications inbound when the 15 minutes are up. Granted this will be a bit harder to do, especially if your not familiar with Wireshark.

- Mumble shouldn't be cutting out your entire game, as it's an external application that plugs into the game. (It starts as a separate executable when you click play)

- Try a different connection? If you have a wireless card just ask a neighbor to borrow it for testing or something. If problem persists, it has to be a client issue, or something on your computer.
Switchback is offline
Last edited by Switchback; 2015-06-07 at 23:03..
Reply With Quote
Old 2015-06-08, 13:31   #4
Steeps
Supporting Member

Steeps's Avatar
Default Re: Cannot play more than 15 minutes before disconnecting, in ANY server.

Quote:
Originally Posted by [TSS]FrankDaTank1218 View Post

-Using a Comcast modem
THIS is your problem. I was using the 2-in-1 Comcast "Gateway" for quite some time before finally getting completely fed up over how terrible (that doesn't even begin the describe the thing) it is. I was having to call Comcast at least twice a month because of my connection issues all due to their "Gateway."


PLEASE save yourself the trouble (and the $8 per month fee they charge for "renting" a device) and buy this modem (8,100 reviews don't lie):

Amazon.com: ARRIS / Motorola SurfBoard SB6121 DOCSIS 3.0 Cable Modem - Retail Packaging - Black: Electronics

Buying that modem will pay itself off after nine months of use because you won't have to buy Comcast $8 a month for their shitty gateway device.

IT WILL solve all of your connectivity problems! Since buying that modem a few months ago, I have lost connection only ONE time compared to multiple times a month with the gateway device.


Steeps is offline Reply With Quote
Old 2015-06-12, 03:46   #5
TheMerchantOfMenace
Supporting Member

TheMerchantOfMenace's Avatar
Default Re: Cannot play more than 15 minutes before disconnecting, in ANY server.

Since 1.3 I was screwed, constant CTDs, wasn't able to play for more than 1/2 hr to 1 hr without crashing... used to be able to play 9, 10, 11+ hour non-stop marathons before getting any kind of memory errors or crashes with the PR 1.2 and earlier versions.

Installed a fresh new Win 7 partition, installed it as 32-bit 'cause was thinking about using some sound-control program talked about in the forums here somewhere, don't remember what it was.

I'd forgot, however, about the 4GB memory limit with 32-bit installations, so don't know if that had anything to do with it, but even on that brand new partition with minimal apps installed, I was still getting constant CTDs.

Yesterday I installed a brand new 64-bit Win 7 version, and this evening I played several hours without any troubles at all. Actually, on the other partitions, I couldn't load the new Nuijamaa map, it would CTD me when the map load finished and the Squad Assignment button would pop up on the lower right of the load screen.

This evening everything worked flawlessly for at least 3 hrs. Still a bit early to be 100% certain that all is fixed, but looks as though all is resolved and PR 1.3 is solid on my system now... on my Win 7 64-bit fresh install, and I have a firewall and security software installed on here.

If you have a 64-bit Win 7 CD, try to partition off a 60GB, and install a fresh new Win 7, install PR, and you should be fine.

>>> Better yet, go buy a $100.00 Samsung 850 Pro and install your partition and game to this drive and watch it fly! You'll never go back to a HDD (still using all my HDDs for data storage, of course).
TheMerchantOfMenace is offline Reply With Quote
Old 2015-06-12, 11:14   #6
Steeps
Supporting Member

Steeps's Avatar
Default

Quote:
Originally Posted by TheMerchantOfMenace View Post
Since 1.3 I was screwed, constant CTDs, wasn't able to play for more than 1/2 hr to 1 hr without crashing... used to be able to play 9, 10, 11+ hour non-stop marathons before getting any kind of memory errors or crashes with the PR 1.2 and earlier versions.


How does your post in any way relate to what OP posted? He didn't mention anything about crashing. He is saying he gets randomly disconnected from games all the time.


Steeps is offline Reply With Quote
Old 2015-06-12, 11:37   #7
TheMerchantOfMenace
Supporting Member

TheMerchantOfMenace's Avatar
Default Re: Cannot play more than 15 minutes before disconnecting, in ANY server.

Quote:
Originally Posted by Steeps View Post
How does your post in any way relate to what OP posted? He didn't mention anything about crashing. He is saying he gets randomly disconnected from games all the time.
Doh! So many ppl I talked to on game were complaining about constantly crashing to desktop, when I saw "Cannot play for more than 15 mins"... I just assumed the rest, without properly interpreting the "disconnecting" part of the subject.

Nevermind the post then.
TheMerchantOfMenace is offline Reply With Quote
Old 2016-05-09, 02:19   #8
tankninja1

tankninja1's Avatar
Default Re: Cannot play more than 15 minutes before disconnecting, in ANY server.

I have this same problem on TWC but with my own modem and it can happen every 15 minutes but sometimes happens every 1,2,3 hours.

Also I am always skeptical of Arris products since the TWC loan device is an Arris and it runs only a step above 1990s dial up with very frequent ping spikes, signal loss, and device resets.

tankninja1 is offline Reply With Quote
Reply


Tags
disconnecting, minutes, play, server
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 02:50.