project reality header
Go Back   Project Reality Forums > Project Reality Support > General Technical Support
30 Jun 2022, 00:00:00 (PRT)
Register Developer Blogs Project Reality Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 2013-05-08, 10:16   #1
Davos
Default Is my iGPU workin?

My system:
Toshiba L850-1C9
8 GB DDR3 RAM
i7-3610QM (HD 4000 ?)
AMD 7670M 2GB

As the title says, my iGPU is maybe not workin. It is not listed in my Device Manager and GPU-Z. And my graphics card is getting really hot, about 50 - 60 Degrees, even if I`m just writing.

I tried to install the newest Toshiba Intel HD 4000 Drivers, but the setup said, that my system does not meet the minimum requriments to install it.

I also tried to go into the BIOS, but it had not the option to turn on Dynamic Graphic switch or something like that.

Davos is offline Reply With Quote
Old 2013-05-08, 12:48   #2
Spook
Supporting Member

Spook's Avatar
Default Re: Is my iGPU workin?

did you deinstall your radeon drivers first? Its not possible to use iGPU and dGPU at the same time.

Spook is offline Reply With Quote
Old 2013-05-08, 18:44   #3
[R-DEV]​LITOralis.nMd
Lead Support Technician
Supporting Member
Default Re: Is my iGPU workin?

1. Use ATI Catalyst to adjust
2. Set Windows Power management to anything BUT NOT *High Performance* and NOT *Gaming* , adjust power settings for battery usage or power outlet usage as you see fit.
3.
Quote:
I’d like to know the ‘Catalyst Control Center’ version installed on your computer. Please follow the steps mentioned below to find out the version.
Open ‘Catalyst Control Center’ by clicking the Start button . In the search box, type ‘Catalyst Control Center’, and then, in the list of results, click ‘Catalyst Control Center’.
Click on ‘Information’ tab in the left.
Click on ‘software’ under ‘Information’ tab.
Let me know the catalyst version on your computer.

Also, I’d like to know if you see ‘Switchable Graphics’ under ‘Power’ section in the ‘Catalyst Control Center’.
If the HD 4000 is not showing up at all, you need to do this:

Quote:
I’d suggest you uninstall the ‘catalyst control center’ & ‘Intel HD 4000’ from Programs and features under the control panel.

Then reinstall the ‘Intel HD 4000’ first and then reinstall ‘AMD RADEON HD 7670M’ drivers & ‘catalyst control center’ in sequence.

LITOralis.nMd is offline Reply With Quote
Old 2013-05-08, 19:09   #4
Spook
Supporting Member

Spook's Avatar
Default Re: Is my iGPU workin?

Wait, so its possible to simply choose between igpu and dgpu with Catalyst? I always thought the iGPU is only activated when no graphicscard is installed.

Spook is offline Reply With Quote
Old 2013-05-08, 19:14   #5
[R-DEV]​LITOralis.nMd
Lead Support Technician
Supporting Member
Default Re: Is my iGPU workin?

Yes it is possible to choose which GPU is being used in the power management section of Catalyst which affects all programs, you can also choose which GPU is used in the per program options in Catalyst, you can also choose which GPU is used (globally again) in the Windows Power management options,

LITOralis.nMd is offline Reply With Quote
Old 2013-05-10, 15:43   #6
Davos
Default Re: Is my iGPU workin?

There was no Switchable Graphics option in CCC , and I had version 13.3.

I did uninstall, the AMD Software with Control Center, Devices Manager and Driver Sweeper and restarted my laptop. Now I was running with Microsoft Basic Graphic Driver.

Next i downloaded the Intel hd Display Driver for my Toshiba Laptop: display-en-20121026072519

The result was, that I was able the extract it, but it not started the installer, as mentioned in the setup.
As I opened the file directory, and started "tinstall" it said: "Your system does not meet the minimal requirements."

Suddenly my screen got dark for a couple of seconds, and at some reason my 7670 was activated again.


I wonder if I have a iGPU ??
The i7-3610 should have a hd 4000, or not?


Intel Core i7 3610QM Notebook Processor - NotebookCheck.net Tech

Davos is offline Reply With Quote
Old 2013-05-11, 08:33   #7
Pedz
Supporting Member

Pedz's Avatar
Default Re: Is my iGPU workin?

Quote:
Originally Posted by Davos View Post

I wonder if I have a iGPU ??
The i7-3610 should have a hd 4000, or not?


Intel Core i7 3610QM Notebook Processor - NotebookCheck.net Tech
Yes you'll have the HD 4000 built onto that i7 chip.

With mobile chipsets they normally allow load-based switching or even application based switching. It may be part of Windows power management or ATI, I remember my laptop had both i7 + ATI GPU (6660 maybe?) and I had a switch to turn it on and off, on that laptop (physical switch), maybe theres some application from toshiba to do the same?


Also with drivers, try direct from Intel
https://downloadcenter.intel.com/Sea...06&FamilyId=24


Another thing to try:
Download GPU-Z
GPU-Z Video card GPU Information Utility

Then run it and it will tell you what graphics is enabled. It may just be that your GPU is in a hot part of the package of your laptop, and without it being powered and fanned, it'll keep warm.
Otherwise, the OEM (Toshiba) may not have implemented a switch, for cost saving reasons or something else? Not totally sure about that, maybe a google search will discover the answer


Pedz is offline Reply With Quote
Old 2013-05-11, 09:19   #8
Davos
Default Re: Is my iGPU workin?

When I installed the driver from Intel, the setup failed again, with the message mentioned before.

GPU-Z recognizes only my 7670.

I can`t find anything helpful with Google search

Davos is offline Reply With Quote
Old 2013-05-12, 08:16   #9
Davos
Default Re: Is my iGPU workin?

Ok, I found the reason for this.
Toshiba has disabled for some reason the hd 4000 on all L850 Laptops, so I cant use it.
So I have to deal with a shorter battery life time.

Davos is offline Reply With Quote
Reply


Tags
igpu, workin
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 08:13.