project reality header
Go Back   Project Reality Forums > Project Reality Support > PR:BF2 Support
18 Nov 2018, 00:00:00 (PRT)
Register Forum RulesDeveloper Blogs Project Reality Members List Search Today's Posts Mark Forums Read
PR:BF2 Support Help and support regarding PR:BF2 installation and in-game issues

Reply
 
Thread Tools Display Modes
Old 2015-07-22, 02:24   #31
DesmoLocke
Supporting Member

DesmoLocke's Avatar
Send a message via AIM to DesmoLocke Send a message via Skype™ to DesmoLocke
Default Re: Lost connection to server.

I haven't able to nail down a solution yet. I'll report back if I do.

PR player since 0.5 (Feb 2007)
DesmoLocke is offline Reply With Quote
Old 2015-07-23, 19:47   #32
Pum
Default Re: Lost connection to server.

Dayton, Ohio here as well with TWC as my ISP.

From what I've gathered, the connection issue isn't at all completely isolated to PR(could just be me, but I'm willing to bet after some testing we'll figure out it isn't just PR); it just seems as such from the way BF2/PR handle gigantic spikes in ping (via an abrupt disconnect).

I've noticed packet loss, ping spikes up to 8000 all over the past month. And sure enough, these several thousand millisecond spikes in ping happen when I lose connection in PR.

I've ruled out my modem/router/computer being the issue 100%. Tested across 3 Windows PCs, 4 Android devices, three different modems, connected to every coax cable in the house and the results were the same: unacceptable packet loss and ping spikes. TWC of course denies it being anything on their end and blames my equipment.

For any of you having the issue do the following and report back in

1. Open command prompt and run it as administrator (Start>Run>cmd>right click run as administrator)
2. Enter the following without quotes "ping -t google.com >C:\pingtest.txt" (if you don't have a C drive or don't want to use it, replace C with wherever you want the ping test to output)
3. Let it run for 1-2 hours, longer if you want
4. When you've finished hit ctrl-C to end the command and then open the text file and paste the bottom 4 lines
Pum is offline Reply With Quote
Old 2015-07-25, 22:43   #33
Martychus
Default Re: Lost connection to server.

Quote:
Originally Posted by Pum View Post
Dayton, Ohio here as well with TWC as my ISP.

From what I've gathered, the connection issue isn't at all completely isolated to PR(could just be me, but I'm willing to bet after some testing we'll figure out it isn't just PR); it just seems as such from the way BF2/PR handle gigantic spikes in ping (via an abrupt disconnect).

I've noticed packet loss, ping spikes up to 8000 all over the past month. And sure enough, these several thousand millisecond spikes in ping happen when I lose connection in PR.

I've ruled out my modem/router/computer being the issue 100%. Tested across 3 Windows PCs, 4 Android devices, three different modems, connected to every coax cable in the house and the results were the same: unacceptable packet loss and ping spikes. TWC of course denies it being anything on their end and blames my equipment.

For any of you having the issue do the following and report back in

1. Open command prompt and run it as administrator (Start>Run>cmd>right click run as administrator)
2. Enter the following without quotes "ping -t google.com >C:\pingtest.txt" (if you don't have a C drive or don't want to use it, replace C with wherever you want the ping test to output)
3. Let it run for 1-2 hours, longer if you want
4. When you've finished hit ctrl-C to end the command and then open the text file and paste the bottom 4 lines
I did it for 2 hours and here's the what it says:

Packets: Sent = 7192, Received = 7191, Lost = 1 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 11ms, Maximum = 516ms, Average = 25ms
Control-C
Martychus is offline Reply With Quote
Old 2015-08-02, 16:12   #34
Rifleman1989
Default Re: Lost connection to server.

Anyone else have any luck with resolving this issue?
Rifleman1989 is offline Reply With Quote
Old 2015-08-04, 02:41   #35
NO FUN ALLOWED
Supporting Member

NO FUN ALLOWED's Avatar
Default Re: Lost connection to server.

Quote:
Originally Posted by Rifleman1989 View Post
Anyone else have any luck with resolving this issue?
Nope, still unable to play the game.

NO FUN ALLOWED is offline Reply With Quote
Old 2015-08-04, 05:18   #36
Heedicalking
Default Re: Lost connection to server.

I would also like this to be fixed. I tried playing and I can usually go 15 minutes at most before I lose connection.
Heedicalking is offline Reply With Quote
Old 2015-08-04, 18:26   #37
VirusCodeX
Default Re: Lost connection to server.

I've been having this problem too and cannot usually play a full game. It says connection to the server has been lost and kicks me back to the server browser. I am on Time Warner Cable too with a stable 30mbs connection. I've tried EVERYTHING. I've searched for this problem and tried every suggestion I could find and nothing has worked. I did go into Mumble settings and clicked advanced then under options I turned off "QoS" and after that I was able to play a full game but next round I lost connection again. I'm going to test again and see if I can stay connected another round then try turning on the "TCP" option in Mumble to see if that makes any difference. The reason why I'm focusing on Mumble now is because I've tested out every other suggestion out there and nothing has fixed my connection issues so far.
VirusCodeX is offline Reply With Quote
Old 2015-08-04, 18:33   #38
VirusCodeX
Default Re: Lost connection to server.

It is kind of weird though that most of these connection issues are with people on Time Warner Cable. Comcast was another one a lot of people had problems with trying to play PR. Some people suggested it was ISP's doing deep packet inspection and that was causing you to lose connection. Other people also said that Arris modems was the culprit for losing connection (I do have an Arris modem too). All I know is I've tried everything and nothing has worked so far.
VirusCodeX is offline Reply With Quote
Old 2015-08-04, 22:41   #39
Martychus
Default Re: Lost connection to server.

Quote:
Originally Posted by VirusCodeX View Post
It is kind of weird though that most of these connection issues are with people on Time Warner Cable. Comcast was another one a lot of people had problems with trying to play PR. Some people suggested it was ISP's doing deep packet inspection and that was causing you to lose connection. Other people also said that Arris modems was the culprit for losing connection (I do have an Arris modem too). All I know is I've tried everything and nothing has worked so far.
Yeah I've read that Arris modems do cause problems and I too have an Arris modem. I have Optimum so I don't think it would be those ISP's but who knows. Hopefully I can get a new modem to see if it helps.
Martychus is offline Reply With Quote
Old 2015-08-04, 23:02   #40
VirusCodeX
Default Re: Lost connection to server.

Try turning off "QoS" under advanced settings in Mumble. In the PR launcher go to options then Mumble then launch Mumble. I turned that setting off and I've played 2 full games without getting disconnected. Kinda early to tell if it's a fix cause I could just be getting lucky but give it a shot and see if it works for you guys. I'll report back if I start getting constantly disconnected again.
VirusCodeX is offline Reply With Quote
Reply


Tags
connection, lost, server
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 00:10.