project reality header
Go Back   Project Reality Forums > PR:BF2 Mod Forums > PR:BF2 Bugs
04 Dec 2021, 00:00:00 (PRT)
Register Developer Blogs Project Reality Members List Search Today's Posts Mark Forums Read
PR:BF2 Bugs If you find a bug within PR:BF2 (including PRSP), please report it here.

Reply
 
Thread Tools Display Modes
Old 2014-01-19, 19:56   #1
tatne
Default Few 1.1 problems

1.0 worked great for me but when 1.1 update got released I've encountered few problems.
Only 1 of them game breaking for me.

1. Every time I launch PR the ingame intro has VERY bad framerate and it takes about three times as long to finish it than it used to take when it worked the normal way. At the end when it says "Project Reality" it kind of "hangs" and then I have to alt-tab to windows and back to game and it'll load main menu.

2. When loading a map @ 54% audio loops and game stops responding for some time and then it warps to loading complete.

3. I've managed to play 1.1 earlier but today I joined 2 different servers (HOG and PRTA) and when I finished loading map and pressed Squad deployment as always but then spawn screen never came up. I couldn't open it at all. The only buttons that actually did something was ESC, page up and page down.
tatne is offline Reply With Quote
Old 2014-01-20, 01:55   #2
[R-DEV]​LITOralis.nMd
Lead Support Technician
Supporting Member
Default Re: Few 1.1 problems

For problem 1:
GO to PRLauncher->Support->Utilities->CLick to run each utility except the update Punkbuster.
GO to PRLauncher->Options->Global Tab->UNTICK the View INtro Movies box->Click Apply.
That should fix that problem.

For problem 2:
Try defraggin the drive you have PR installed on, also, if you post your system specs we might be able to give more help.

For problem 3:
Need your system specs,
Also what type of BF2 installation? Steam, Origin, Retail DVD, etc?

LITOralis.nMd is offline Reply With Quote
Old 2014-01-20, 10:10   #3
tatne
Default Re: Few 1.1 problems

System Information
------------------
Operating System: Microsoft Windows 7 Ultimate (6.1.7601)
Architecture: 64-bit
Current Culture: Finnish (Finland)
Motherboard: ASRock N68-S3 UCC
Processor: AMD Phenom(tm) II X4 840 Processor (Physical: 4, Logical: 4)
Memory: 4,00 GB
DIMM Modules: DIMM1: 4,00 GB @ 667 MHz
Page File: 7,90 GB
.NET Framework: 4.5.1, Runtime: 4.0.30319.18408

Display Information
-------------------
Display Device(s): BenQ G2222HDL D-SUB on NVIDIA GeForce GTX 560
Display Mode(s): 1920 x 1080 (32 bit) @ 60 Hz
Driver Version: 9.18.13.3165 (331.65)
Display Memory: 1024,00 MB
Multisampling: 2, 4, 8
DPI: 96 (100%)

Audio Information
-----------------
Primary Playback: Speakers (High Definition Audio
Primary Recording: Microphone (High Definition Aud
Open AL Renderer: Software
EAX: True
EAX 1.0: False
EAX 2.0: True
EAX 3.0: False
EAX 4.0: False
EAX 5.0: False
X-RAM: False

Disk Information
----------------
Install Path: D:\Program Files (x86)\EA GAMES\Battlefield 2
Free: 402,13 GB, Total: 850,36 GB, FS: NTFS, SSD: False
Mod Path: D:\Program Files (x86)\EA GAMES\Battlefield 2\mods\pr
Free: 402,13 GB, Total: 850,36 GB, FS: NTFS, SSD: False
Profiles Path: C:\Users\xxx\Documents\ProjectReality\Profiles
Free: 27,49 GB, Total: 81,05 GB, FS: NTFS, SSD: False
Update DL Path: C:\Users\xxx\AppData\Local\Project Reality\Project Reality BF2\Downloads
Free: 27,49 GB, Total: 81,05 GB, FS: NTFS, SSD: False
Update Log Path: C:\Users\xxx\AppData\Local\Project Reality\Project Reality BF2\UpdateLogs
Free: 27,49 GB, Total: 81,05 GB, FS: NTFS, SSD: False

Game Information
----------------
CD Key Valid: True
CD Key Type: Dashless (Normal)
Installed Mods: bf2, pr, xpack
Current Mod: pr
BF2 Version: BF2 1.5
PR Version: 1.1.1.0
Language: english
Debug Available: False
Large Address: True
Supported Hardware: None

Profile Information
-------------------
Profile 0001: ;_;tatneasd
Type: Online
Last Used Profile: True
View Intro: True
Fullscreen: True
Display Mode: 1920x1080@60Hz
Display Mode Valid: True
Graphics Scheme: Medium
Multisampling: Off
VSync: True
Terrain Quality: Low
Effects Quality: Medium
Geometry Quality: Low
Texture Quality: Medium
Lighting Quality: Low
Dynamic Shadows: Medium
Dynamic Lights: Medium
Texture Filtering: Medium
Audio Provider: Software
Provider Valid: True
Audio Quality: High
EAX: True


I have retail version of BF2.
I managed to play pr after this thread.
That time intro played normal and spawn screen came up normally.
It seems to be random for me.

EDIT: I forgot to mention that when the intro movie was playing the windows tray bar flickered through the fullscreen game at the time it has poor framerate.
Now I tried to launch game 3 times and go play (with intro disabled) I couldn't see the spawn screen.
But even without the intros the tray bar flickered through game when I had that black screen when launching game.

Kinda hard to describe, hope you understood and this helps.
tatne is offline
Last edited by tatne; 2014-01-20 at 11:55..
Reply With Quote
Old 2014-01-20, 15:14   #4
Daniel
Banned
Supporting Member
Default Re: Few 1.1 problems

Wow, your RAM...

DIMM Modules: DIMM1: 4,00 GB @ 667 MHz

Only ONE module not even two, and THAT even running at just 667 MHz? o_O Normal is 1333 MHz today... That may be causing issues. 4 GB should be enough though for PR, especially with 64 bit OS.
Daniel is offline Reply With Quote
Old 2014-01-20, 17:19   #5
tatne
Default Re: Few 1.1 problems

I was JUST about to ask what the hell is that all about.
It should be 4gb 1333mhz!
And now I loaded default CPU clocks it says it's only 4gb 400mhz.

PR used to work great before 1.1.1.0 patch.
tatne is offline Reply With Quote
Old 2014-01-20, 17:32   #6
Psyrus
Retired PR Developer
Default Re: Few 1.1 problems

Quote:
Originally Posted by Daniel View Post
Wow, your RAM...

DIMM Modules: DIMM1: 4,00 GB @ 667 MHz

Only ONE module not even two, and THAT even running at just 667 MHz? o_O Normal is 1333 MHz today... That may be causing issues. 4 GB should be enough though for PR, especially with 64 bit OS.
This is why people say a little knowledge is dangerous. DDR stands for double-data-rate, so you take the effective clock and double it for the data rate. Feel free to do some short reading here:
https://en.wikipedia.org/wiki/Double_data_rate
https://en.wikipedia.org/wiki/DDR_SDRAM

667*2 = ?

The fact that he only has his RAM running in single channel should not provide a bandwidth bottleneck, as it's already measured in GB/s at tiny latencies.
Psyrus is offline
Last edited by [R-DEV]Psyrus; 2014-01-20 at 17:38..
Reply With Quote
Old 2014-01-21, 19:29   #7
[R-DEV]​LITOralis.nMd
Lead Support Technician
Supporting Member
Default Re: Few 1.1 problems

Quote:
EDIT: I forgot to mention that when the intro movie was playing the windows tray bar flickered through the fullscreen game at the time it has poor framerate.
Now I tried to launch game 3 times and go play (with intro disabled) I couldn't see the spawn screen.
But even without the intros the tray bar flickered through game when I had that black screen when launching game.
You have a program running in the background that is stealing UI focus. It is likely a program running is the system tray, but it could be several things. It also could be a virus.

The first place to start is shutting down all unneeded background processes.

You can also download a program like CCLeaner CCleaner - PC Optimization and Cleaning - Free Download and install it. OPen it go to Tools->Startup, and see if you can disable unneeded startup programs, it's probably one of those causing this problem.

You can download something like Razer Gamebooster to automate the shutting down of unneeded background processes when you start games. Razer Game Booster Performance Boosting & Screencapture Software - Razer United States

LITOralis.nMd is offline Reply With Quote
Old 2014-01-21, 20:30   #8
boberczus

boberczus's Avatar
Default Re: Few 1.1 problems

I recommend the GameBooster. Installed it 3 days ago and I don't have to restart the game after every round (If I wouldn't do it game usualy CTD during loading). It still occassionally crashes but not much to expect if you have 2Gigs of RAM and VISTA

Yea... right...
boberczus is offline Reply With Quote
Old 2014-01-22, 21:00   #9
tatne
Default Re: Few 1.1 problems

Oh right the flickering thing must be rtss (on-screen clock,cpu and gpu temps and usage). It used to work fine before last update tho.
tatne is offline Reply With Quote
Reply


Tags
problems
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 04:23.