project reality header
Go Back   Project Reality Forums > Project Reality Support > General Technical Support > Software & Operating Systems
19 Jun 2019, 00:00:00 (PRT)
Register Developer Blogs Project Reality Members List Search Today's Posts Mark Forums Read
Software & Operating Systems Discussion on Computer Software & Operating Systems

Reply
 
Thread Tools Display Modes
Old 2018-03-18, 21:00   #1
WarGhost
Default Loosing connexion only for this game

Hey;

I'm randomly loosing connexion when playing the game, i'm playing only coop, and the the think is that when i minimize the game and check my internet connexion it seems to be ok but not for the PR game.

If i refresh servers list after having lost connexion with the server it does not show up and keep waiting for servers list.

Then if i quit the game and run it again it's working just fine again but will lose connexion after few minutes.

I'm using avast antivirus and zoneAlarm firewall where i did allow all acces to the game.

I have others games whitch are running just fine all the time.

Is this mater of opening some ports on rooter or something else ?

I even reinstalled fresh windows and even buy new wifi adapter but nothing seems to fix the problem.

I'm using windows 7 Professional 64 bit.

I apreciate any help to fix this, thanks.
WarGhost is offline Reply With Quote
Old 2018-03-20, 17:59   #2
Vista
Default Re: Loosing connexion only for this game

I've been having the same problem on my PC at home. When I'm using TS I have absolutely 0% packet loss, others can hear me and I can hear them perfectly, but in PR my connection is extremely shitty, I rubberband endlessly and end up losing connection to the server.

I'm also using avast, but on Windows 10. I wonder if avast is the issue?
Vista is offline Reply With Quote
Old 2018-03-21, 08:09   #3
WarGhost
Default Re: Loosing connexion only for this game

No man avast is not the issue cz i still can ping google and play others games when PR loses connexion.

But i'm testing something and seems to be working (for now), if i did not posted that yet, it's cz i need to wait 2 - 3 days to be sure.

What i did is diactivate MAC adress filter on my rooter and after that:

1 - The Game seems to be working without loosing connexion (1 day test).
2 - Windows network diagnose still saying that i have problem with network and acces point and it does fix it but the problem seems to come back everytime.

So i'm not sure if diactivating MAC filter on rooter did permantly fix the problem or not.

If you wana test that, be sure your bandwidth is not overloaded (mass download, wathching movies) by someone else at your home cz in my experience PR is sensitive to that somehow, i may recomand DEVs to add antilag system in the game, not quiet sure they did or not but if they did then i recomand them to rise max allowed ping to 500.

It is indeed home network causing this (PC or Rooter configs) but the game can contribute to keep player in server like the others games do.

I let you know after 3 days testing and this will be tomorrow at the end of the day.
WarGhost is offline
Last edited by WarGhost; 2018-03-21 at 08:21..
Reply With Quote
Old 2018-03-21, 08:54   #4
[R-DEV]​AlonTavor
PR:BF2 Developer
Default Re: Loosing connexion only for this game

The netcode for this engine was written in 2004 and we never had the source code. So adding more anti lag is impossible.
Furthermore, this engine already goes to huge lengths to hide lag/packet loss.

I've seen this issue with a few people before in the last 3 years and I always believed it's related to something on the router. Perhaps a firewall on it mistaking game data as an attack.

If you would like to dig all the way in as to what causes this, I suggest installing Wireshark and capturing a session that disconnects. Specifically in the capture I would look for either:
-Many packets going out but none coming in (specifically from the game server) at moment of disconnect.
-ICMP "Port unreachable" or "destination unreachable" coming from the router.

I would also check if your router has logs. My old one logged things it's firewall blocked.
AlonTavor is offline Reply With Quote
Old 2018-03-21, 10:54   #5
WarGhost
Default Re: Loosing connexion only for this game

Thanks for the reply,

I have just disabled firewall on rooter and here is my log file at the time i'm not playing the game (i post another if i lose connexion with the game again).

1/2/2000 19:38:52> Last errorlog repeat 1 Times
1/2/2000 19:38:52> dns2str too long 1
1/2/2000 19:38:52> dns2str too long 3
1/2/2000 19:38:52> Last errorlog repeat 3 Times
1/2/2000 19:38:52> dns2str too long 55
1/2/2000 19:38:52> dns2str too long 1
1/2/2000 19:38:52> Last errorlog repeat 1 Times
1/2/2000 19:38:52> dns2str too long 4
1/2/2000 19:38:52> dns2str too long 21
1/2/2000 19:38:52> dns2str too long 11
1/2/2000 19:38:52> dns2str too long 24
1/2/2000 19:38:52> dns2str too long 43
1/2/2000 19:38:52> dns2str too long 3
1/2/2000 19:38:52> dns2str too long 8
1/2/2000 19:38:52> dns2str too long 4
1/2/2000 19:38:52> dns2str too long 16
1/2/2000 19:38:52> dns2str too long 0
1/2/2000 19:38:52> dns2str too long 5
1/2/2000 19:38:52> dns2str too long 0
1/2/2000 19:38:52> dns2str too long 5
1/2/2000 19:38:52> dns2str too long 1
1/2/2000 19:38:52> dns2str too long 5
1/2/2000 19:38:52> dns2str too long 33
1/2/2000 19:38:52> dns2str too long 4
1/2/2000 19:38:52> dns2str too long 27
1/2/2000 19:38:52> dns2str too long 10
1/2/2000 19:38:52> dns2str too long 2
1/2/2000 19:38:52> netMakeChannDial: err=-3000 rn_p=8048da10

My rooter is TP-Link TD-W8961N.

Now i'm trying to use wireshark and will see what it does.

One again thanks
WarGhost is offline Reply With Quote
Old 2018-03-21, 11:02   #6
[R-DEV]​AlonTavor
PR:BF2 Developer
Default Re: Loosing connexion only for this game

in wireshark I would use the following filter:

Code:
ip.addr == SERVERIP || ip.addr == ROUTERIP || icmp
AlonTavor is offline Reply With Quote
Old 2018-03-22, 07:44   #7
WarGhost
Default Re: Loosing connexion only for this game

After i have diactivated mac filter and firewall on my rooter the game seems to be ok within 3 days of test.
I will consider this issue resolved then.

Thank you so much for you help.
WarGhost is offline Reply With Quote
Reply


Tags
connexion, game, loosing
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 11:32.