project reality header
Go Back   Project Reality Forums > Project Reality Support > General Technical Support
22 Nov 2019, 00:00:00 (PRT)
Register Developer Blogs Project Reality Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 2019-02-27, 21:35   #11
temexter
Supporting Member

temexter's Avatar
Default Re: WYSIWYG editor not available on forums

Bubpiti bump



temexter is offline Reply With Quote
Old 2019-03-03, 23:34   #12
[R-DEV]​Senshi
PR:BF2 Developer
PR Server License Administrator

Senshi's Avatar
Default Re: WYSIWYG editor not available on forums

I'm pretty sure it's not something we did.

Go to your User CP -> Edit Options, then scroll down to Miscellaneous.

There you can select which editor type you prefer. Pick the bottom one for the full WYSIWYG.

However, there's a caveat: It doesn't work on all browsers, most notably it does not seem to work on all Chrome-based browsers.

Also, no guarantees if it still works properly at all, never used it. I tend to hate them for messing up my formatting more than it helps, but to each his own .

EDIT: To clarify - the WYSIWYG has not been updated by the vbulletin team in approximately ten years, and there's a bunch of bugs that prevent it from working in Chrome. So this will never get fixed.


Also, sorry for not noticing this sooner. For website/homepage related topics, I recommend contacting me directly using PM, Email, Discord or whathaveyou.

Senshi is offline Reply With Quote
Old 2019-06-05, 11:17   #13
temexter
Supporting Member

temexter's Avatar
Default Re: WYSIWYG editor not available on forums

Thanks for response Senshi!

Now i'm quite late with answer, dunno if i missed alert forum, i get usually get alerts from new posts on forums i have subbed and threads i have subbed, weird

Okay, to clarify the problem, the point is missing button in editor toolbar, in far right top corner, which switches between BBCODE and WYSIWYG:



So i'm kinda in WYSIWYG mode all the time and if i paste BBCODE in editor it just shows it as BBCODE instead of WYSIWYG, as i can't paste in BBCODE mode and then switch to WYSIWYG to finish up the post. That's how i did until something happened in September 2017.

I checked the editor mode in user settings already back in the day and it has no effect in this issue.

Sorry for being ambiguous, or erroneous in my OP, and forgot to clarify, the point is not WYSIWYG missing, it's working, but it's the only option, like said...

And all formatting works fine for me (at least) either done with editor tools or by writing BBCODE, which i usually do, i copy the announcement from our XenForo forum in BBCODE and paste it here and in this case only way to see the actual output is using post preview, as only BBCODE is shown (because like said above, the BBCODE mode option is missing).

Also, like said in OP, i reckon it's some kind of user account setting as rPoXo has the button and i don't.

Update: Jeeez, how can i be so stupid, how in the hell haven't i tested with another browser in the 1st place, 2 years wasting time with dozens of long announcements fiddling with BBCODE and i just tested in Firefox and the button shows. So it is apparently a problem with Chrome, like you suggested (editor works in WYSIWYG mode per se, but the editor mode can't be changed).

Problem solved, case closed. Thanks for contribution



temexter is offline
Last edited by temexter; 2019-06-05 at 11:46..
Reply With Quote
Reply


Tags
editor, forums, wysiwyg
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 18:01.