project reality header
Go Back   Project Reality Forums > Project Reality Support > PR:ARMA3 Support > PR:ARMA2 Support Forum Archive
30 Sep 2014, 00:00:00 (PRT)
Register Forum RulesDeveloper Blogs Project Reality Members List Search Today's Posts Mark Forums Read
PR:ARMA2 Support Forum Archive Archived posts from PR:ARMA2 Support Forum

Contact Support Team Frequently Asked Questions Register today!

 
 
LinkBack Thread Tools Display Modes
Old 08-18-2012, 10:26 PM   #1
doveman
Default Mic no longer working in PR

When I was playing PR a week or so ago my mic worked fine but for the last week each time I've played no-one can hear me. I've tested it in TS and it's working fine and I setup a LAN game of vanilla ARMA on my two PC's and VON works fine there as well, just not in PR anymore.

It makes it rather hard to work as part of a team when I can't talk to anyone, so I hope we can find out how to fix this.

EDIT: On an unrelated issue, I keep getting deafened by some sort of squawk noise (reminds me of the end transmission noise on minicab radios). Seems to happen more often during some games than others. Is some numpty just using some sort of app to inject this sound into their mic feed?
doveman is offline
Last edited by doveman; 08-18-2012 at 10:31 PM..
Old 08-19-2012, 12:09 AM   #2
Swedge
Forward Outposts 'R' Us
Supporting Member

Swedge's Avatar
Default Re: Mic no longer working in PR

Hi mate,

1. When you tested the LAN game, how did you test it? Was 2 people involved?

2. When you press your microphone button in PR, does the microphone icon pop up at the bottom left of the screen but people can't hear you? Or does the icon not even pop up?

3. Just out of curiosity, have you ever installed or used the ACRE mod?

4. Just out of curiosity, are you using a steam version of Arma or non-steam?

Cheers,
Swedge


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.

Swedge's
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
.
Mayr's
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
.
Swedge is offline
Old 08-19-2012, 12:43 AM   #3
mad rabbit

mad rabbit's Avatar
Default Re: Mic no longer working in PR

I agree with Swedge and would also add that testing your mic in other applications such as the self test in Skype or Teamspeak 3 may help to identify the problem.

In addition the only time I can ever remember hearing a squawk in game was from ACRE.


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.


New Players:
Please watch this quick official 5 min video to understand the basic controls of PR:ArmA2 and save your squad leader a lot of headache!

To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
mad rabbit is offline
Old 08-19-2012, 12:51 AM   #4
hiddengearz
Default Re: Mic no longer working in PR

i don't think acre would do anything at all, it doesn't change any keys unless you manually change them.


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.


The navy says 70% of the world is covered by water... Well 100% of the world is covered by air...
hiddengearz is offline
Old 08-19-2012, 05:40 AM   #5
doveman
Default Re: Mic no longer working in PR

Quote:
Originally Posted by Swedge View Post
Hi mate,

1. When you tested the LAN game, how did you test it? Was 2 people involved?

2. When you press your microphone button in PR, does the microphone icon pop up at the bottom left of the screen but people can't hear you? Or does the icon not even pop up?

3. Just out of curiosity, have you ever installed or used the ACRE mod?

4. Just out of curiosity, are you using a steam version of Arma or non-steam?

Cheers,
Swedge
Hi Swedge

1. I just created a game on my main PC, connected to it with my 2nd PC and checked that when I used my mic (VON and direct channel) that it transmitted to my 2nd PC.

2. Yeah, the icons appear so it is triggering, just no-one can hear me.

3. I have installed the ACRE mod (and it's plugin in TS).

4. I'm using a non-steam version.

I normally use Windows 7 x64 but I've got ArmA setup under XP as well, so I'll try that next time and see if it works under that.
doveman is offline
Old 08-19-2012, 05:44 AM   #6
doveman
Default Re: Mic no longer working in PR

Quote:
Originally Posted by mad rabbit View Post
I agree with Swedge and would also add that testing your mic in other applications such as the self test in Skype or Teamspeak 3 may help to identify the problem.

In addition the only time I can ever remember hearing a squawk in game was from ACRE.
Hi mad rabbit

Yeah, I did the self test in TS first to make sure the mic was working and that's fine.

I haven't used ACRE in a while but I don't think this sound is the same as the one I heard when using that. It's more annoying! I might try recording the audio next time so I can let you hear it.
doveman is offline
Old 08-19-2012, 05:45 AM   #7
doveman
Default Re: Mic no longer working in PR

Quote:
Originally Posted by hiddengearz View Post
i don't think acre would do anything at all, it doesn't change any keys unless you manually change them.
Yeah, I think you just have to remap/unmap the VON keys when using ACRE but I mapped those back (Capslock for VON and ` for Direct Channel).
doveman is offline
Old 08-19-2012, 07:23 AM   #8
galzohar

galzohar's Avatar
Default Re: Mic no longer working in PR

If your name doesn't show, it's your PTT key not defined and has nothing to do with the microphone.

If your name shows, then your PTT key is fine, and it's either your microphone or any setting related to your microphone, either in-game or out of game. If it's only in PR, I'd check the microphone volume setting in the PR menus, and just in case also in the menus when you start the game with no mods.

Are you using the same player profile for PR and for vanilla and/or other mods? If the player profile is different, the settings might differ, which might cause it to look like a PR problem while it's really just you having different settings for the player profile you are using for PR.

In any case, I doubt it's a bug in PR...

You don't mess with the Zohar!

To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.


My YouTube Channel:
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.

Arma 2 Israel:
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
galzohar is offline
Old 08-19-2012, 08:20 AM   #9
doveman
Default Re: Mic no longer working in PR

Quote:
Originally Posted by galzohar View Post
If your name doesn't show, it's your PTT key not defined and has nothing to do with the microphone.

If your name shows, then your PTT key is fine, and it's either your microphone or any setting related to your microphone, either in-game or out of game. If it's only in PR, I'd check the microphone volume setting in the PR menus, and just in case also in the menus when you start the game with no mods.

Are you using the same player profile for PR and for vanilla and/or other mods? If the player profile is different, the settings might differ, which might cause it to look like a PR problem while it's really just you having different settings for the player profile you are using for PR.

In any case, I doubt it's a bug in PR...
I think my name showed but certainly the mic symbol did so the keys were definitely working.

I did check the mic and VON volumes whilst playing and they were fine.

Yeah, I use a profile "doveman" normally and this is used when loading PR as well. I wanted to ask how it knows to use that profile, as the default one in the My Documents/Arma2 folder is just named Main (which is the Windows username) and my doveman profile is under Arma 2 Other Profiles/ so it's always struck me as strange that it uses that but it's the one I want to use anyway so it's no problem, just curious.

As I said, I'll test next time under XP and see if that works, which will at least help to narrow down the problem hopefully.

EDIT: Looking at the profile, the audio settings are as follows. I doubt there's an issue with them though as VON works on the LAN OK. I presume VON uses the arma2oa.exe to transmit, so as long as that's allowed through the firewall it shouldn't be blocked (praa.exe is allowed TCP Out as well though)? My firewall (Comodo) should alert me if something else is trying to access the Internet anyway.

volumeCD=4.7837868;
volumeFX=4.6110706;
volumeSpeech=4.5830116;
volumeVoN=6.5;
vonRecThreshold=0.041809045;
doveman is offline
Last edited by doveman; 08-19-2012 at 08:28 AM..
Old 08-20-2012, 05:41 AM   #10
doveman
Default Re: Mic no longer working in PR

This might be why I'm having this problem: Unable to speak through ingame voice

EDIT: If that is the cause, it seems it was introduced in 95660:
ftp://downloads.bistudio.com/arma2.c...uild_95660.log
[95654] Improved: VoN now uses the same port as the game traffic, should make VoN more reliable (less NAT issues)

I'll try rolling back to 95417 and see if that fixes it.
doveman is offline
Last edited by doveman; 08-20-2012 at 02:28 PM..
 


Tags
longer, mic, working
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:51 PM.


Powered by: vBulletin. ©vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
All Content Copyright ©2004 - 2014, Project Reality.