project reality header
Go Back   Project Reality Forums > Project Reality Support > PR Tech Archives
19 Sep 2014, 00:00:00 (PRT)
Register Forum RulesDeveloper Blogs Project Reality Members List Search Today's Posts Mark Forums Read
PR Tech Archives Archived threads - locked for searching

Contact Support Team Frequently Asked Questions Register today!

 
 
LinkBack Thread Tools Display Modes
Old 07-05-2010, 01:49 PM   #1
cocobutter333

cocobutter333's Avatar
Default [Solved] "your connection to the server has been lost" w/ WLAN

I been crashing to menu constanly (error mesage - "your connection to the server has been lost"), the time a can spend in a game varies i bilive the less cores i use the longer a stay ingame possibly.

- I have tried setting affinity manualy using various amount of cores
- My brother (K.dotman) is on the same network he does NOT have the same problems so may not be the router
- punkbuster seems to be working correctly and is up to date
- I have done the C++ fix

My Spec
- Windows 7 Home Premium 64bit
- AMD3 PhenmonII x4 950 3.4GHz
- 4GB DDR3 RAM 1600MHz
- ASUS M4A87TD motherboard
- ATI HD4770

maybe re installing everything under windows XP compatibility?
cocobutter333 is offline
Old 07-05-2010, 04:33 PM   #2
Sabre_tooth_tigger

Sabre_tooth_tigger's Avatar
Default Re: "your connection to the server has been lost"

It may not seem correct but I think this is more likely to do with the graphics card. Try varying the drivers and use driver cleaner


Turn off aero


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
Sabre_tooth_tigger is offline
Old 07-06-2010, 09:01 PM   #3
thepalerider

thepalerider's Avatar
Arrow Re: "your connection to the server has been lost"

Check Punkbuster B is set to auto re-start(this works for me).
Punk Buster not updated:
Before you go online to join a server
you should:
1. Download pbsvc

2. Start pbsvc installer, you should see options for install, uninstall, test.
3. Run the Uninstaller, then delete the PB folder to remove any leftover files.
4. Restart your computer.

5. reinstall punk buster files with pbsvc( if your using Vista DO NOT set compatibility to XP, run as admin ok)
6. After pcsvc installs, click the "test" option to check the punk buster install you just did.
5. Make sure it comes back "all green"
6.Download pbsetup
(pbsvc DOES NOT install pbsetup.
If your using Vista DO NOT set compatibility to XP, run as admin ok)
7.Create a pbsvc installer shortcut AND pbsetup program shortcut on your desktop.
8.Run pbsetup (from the shortcut on your desktop) add BF2 to the games list, then hit update."

(pbsvc installs the punk buster 'engines' or applications.
PBsetup installs the files/gas the 'engines run)

Check Punkbuster B is set to auto re-start.

Quote:
Originally Posted by =HOG=Romeo_One_Three View Post
Open your Control Panel. Go to Administrative Services. Click

on Services while PR is running. Select Punkbuster B, right click, select properties, select the

recovery tab and make sure they all say "Restart the service" for all three dropdowns. You can do

the same for PB A, but generally speaking, it's the B client that stops responding. Any time you

update PB, you may need to re-do this step.
W7 users = In services ( inside the 'log on' tab) check box which states “Allow this service to interact with the desktop.

Good luck

"There's nothin' like a nice piece of hickory"

I play on
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
where it's all about the teamwork.
thepalerider is offline
Old 08-18-2010, 12:40 AM   #4
vsbf2sniper

vsbf2sniper's Avatar
Send a message via MSN to vsbf2sniper
Default Re: "your connection to the server has been lost"

I've been getting this problem as well "your connection to the server has been lost"
Its driving me crazy. Please help. Vannila is ok.
vsbf2sniper is offline
Old 08-20-2010, 07:18 AM   #5
ubernuka

ubernuka's Avatar
Default Re: "your connection to the server has been lost"

i solved this on my system by changing my internet protocol from ipv6 to ipv4 i have had no probs since except for server crashes.dont know if this would work for everyone but it worked for me.Apparently it is due to my router not having enough ram to run ipv6.
ubernuka is offline
Old 10-16-2010, 02:04 PM   #6
lucky.BOY
Supporting Member

lucky.BOY's Avatar
Send a message via ICQ to lucky.BOY Send a message via Skype™ to lucky.BOY
Default Re: "your connection to the server has been lost"

Hi,
I have similar problem as OP, but:
- I didnt try to change affinity
- I dont know what C++ fix is.
- I have tried the things you suggested, thepalerider, but Pnkbtsr B seems to reset the properties each time i run PR, and beside it it didnt help me.
Vanilla has the same issue as PR.

However, I've tried to connect to my router via cable, and i solved the problem. The downside is that i dont want to be connected via wire, i want wireless connection.
My brother sits beside me on a completely diferent PC and has the same issue.

The question is: what can i do to correct my wi-fi?

My wi-fi card: Acer Npify 802.11b/g/n

My router: ZyXEL P-660HW-T3 v2.

Thanks for response,

-lucky


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
lucky.BOY is offline
Old 10-17-2010, 12:59 AM   #7
Kurt_Russell
Default Re: "your connection to the server has been lost"

I'm also having an issue with this. Went from playing with the occasional crash when the patch was first released to getting booted the second the map is loaded. I've tried reinstalling punkbuster and disabling a few services that were recommended but still no luck. Going to get a cable tomorrow (I'm also using wireless) to see if anything changes. Any suggestions would be fantastic, thanks.
Kurt_Russell is offline
Old 10-17-2010, 06:41 AM   #8
lucky.BOY
Supporting Member

lucky.BOY's Avatar
Send a message via ICQ to lucky.BOY Send a message via Skype™ to lucky.BOY
Default Re: "your connection to the server has been lost"

So, to sum up my problem, why i can play long while on cable, but i DC when i play on WLAN.
What can cause it, and what can fix it?
Thanks for answers.


-lucky


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
lucky.BOY is offline
Last edited by lucky.BOY; 10-21-2010 at 08:55 AM.. Reason: corrected spelling mistakes
Old 10-19-2010, 05:37 PM   #9
eenis

eenis's Avatar
Default Re: "your connection to the server has been lost"

Win7 64 and i loose my connection everytime after about 20 mins. Ive reinstalled PB, done PB setup, Opened all my Ports, Full firewall permissions to Punkbuster A and B.

Anyone have any clue whats happening or how to fix it?
eenis is offline
Old 10-20-2010, 07:37 PM   #10
eenis

eenis's Avatar
Default Re: "your connection to the server has been lost"

Well i switched my sound settings to "hardware" instead of "software" and ive played one match for about an hour. It looks promising but i need to test more. Will reply with my results.
eenis is offline
 


Tags
solved, w or, wlan
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:47 AM.


Powered by: vBulletin. ©vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
All Content Copyright ©2004 - 2014, Project Reality.