project reality header
Go Back   Project Reality Forums > Project Reality Support > PR Tech Archives
25 Nov 2014, 00:00:00 (PRT)
Register Forum RulesDeveloper Blogs Project Reality Members List Search Today's Posts Mark Forums Read
PR Tech Archives Archived threads - locked for searching

Contact Support Team Frequently Asked Questions Register today!

 
 
LinkBack Thread Tools Display Modes
Old 10-26-2008, 10:36 PM   #1
willytee
Default Start up help (warning scree)

Hope this hasnt been posted already. Okay so i downloaded and installed PR. When i go to play the game it seems to stay in the Warning Screen? Anybody know a way to fix this? If it matters i am using Vista.
willytee is offline
Old 10-26-2008, 11:52 PM   #2
[R-DEV]Rudd
PR:BF2 Developer
Supporting Member

[R-DEV]Rudd's Avatar
Default Re: Start up help (warning scree)

Welcome to the forums
http://www.realitymod.com/forum/f27-...-guide-pr.html

I'm assuming that its telling you the warning where you get told to alt-f4 out and use pr.exe? a screenshot would be useful mate.

Quote:
Originally Posted by [R-DEV]fuzzhead View Post
  1. bf2.exe does not exist. Please check your working directory! The system cannot find the file specified!

    • I have Windows XP/Vista:
      Open properties of your Project Reality desktop shortcut - Right click on the shortcut, select Properties.
      Focus on the line called "Start in" (the 2nd writable line from the top).

      - the highlighted line is the one we need to check

      Basically, the line should look like:
      *SOMETHING*\Battlefield 2\

      *SOMETHING* stands for whatever folders you have before the actual BF2 folder. Therefore, if you didn't change the default installation path during the BF2 installation, the line will look like:
      C:\Program Files\EA GAMES\Battlefield 2\

      Once you change the line to what I've said above, simply hit OK and start up the game.

      Windows Vista Users MUST run BF2/PR as administrator (this is not a default setting). To do this:
      - Open properties of your Project Reality shortcut.
      - In one of the tabs tick Run as an administrator.
      - If the box above is gray for whatever reason, simply launch the game by right-click on the shortcut and selecting Run as admin.


    • WARNING! You must run Project Reality by running PR.exe, not BF2.exe.
      Press ALT+F4 and update your shortcuts!


      - Make sure your PR shortcut is setup correctly and you are starting PR with pr.exe and not bf2.exe.

      Open properties of your Project Reality shortcut - Right click on the shortcut, select Properties.

      Now focus on the first writable line from the top, which is called "Target" in the English version of Windows (both XP and Vista).

      The line should look something like:
      C:\Program Files\EA GAMES\Battlefield 2\mods\pr\pr.exe + parameters

      In case you installed BF2 into a different directory than default, ensure that your shortcut is pointing to INSTALLPATH\Battlefield 2\bf2.exe. You can simply edit the target line to correspond to your custom install path (keep everything else (parameters) the same).


      Now it's time to take care of the another writable line underneath the "Target" one. It's called "Start in".

      Make sure it looks like:
      *SOMETHING*\Battlefield 2\

      For Windows Vista, you will need to open up the PR shortcut's properties again and switch over to "Compatibility" tab.

      Focus on the bottom of the window, specifically on the "Privilege Level" part.
      Tick the box left of the "Run this program as an administrator" option.


    • the box mentioned above is gray (non-selectable):
      This occurs when UAC is turned off, in which case the EXE will be run as an administrator as default, and thus you can just start pr.exe up normally. Just to be safe, launch the game by right clicking on the PR shortcut and selecting "Run as administrator".


    • None of the above worked:
      Try the unofficial BAT Scripts launcher I have made a while ago.


To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.

[R-DEV]Rudd is offline
Old 10-29-2008, 06:35 PM   #3
willytee
Default Re: Start up help (warning scree)

I fixed it. It wasnt really a problem loading the game. There was a warning screen telling me a few things.

But what i did was edited my shortcut and added +restart in the shortcut area and it fixed it.

Now i just have to figure out why i have to hit ESC every time it says connection problems when i have ping below 100. . And also a PB problem.


Sigh, searching forums now...

Thanx for the help mate.
willytee is offline
 


Tags
scree, start, warning
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:41 PM.


Powered by: vBulletin. ©vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
All Content Copyright ©2004 - 2014, Project Reality.