Project Reality Forums

Project Reality Forums (http://www.realitymod.com/forum/)
-   PR:BF2 Support (http://www.realitymod.com/forum/f27-pr-bf2-support)
-   -   Win 7 Error 1301 (http://www.realitymod.com/forum/f27-pr-bf2-support/124694-error-1301-a.html)

ThatPieceOfGold 10-04-2013 06:03 PM

Error 1301
 
I have been trying to play PR for about 2 hours now and with no avail i keep getting the 1301 File Verification Error. I really would like to play PR so i would like to fix this soon.

[R-COM]LITOralis.nMd 10-04-2013 06:08 PM

Re: Error 1301
 
Make sure your firewall and or antivirus is not blocking PRLauncher and PRBF2.exe.

[R-COM]LITOralis.nMd 10-04-2013 06:09 PM

Re: Error 1301
 
Also a simplified way to get up and running:

Quote:

Originally Posted by WarGrade (Post 1928823)
I think that i found a solution!!!!
(This worked for me and i don't know if it will work for others)

1. Download 'Portforward Setup Static IP Adress' (completely free)
2. Install it......
3. When you run it, at the bottom there should be a button that says 'Make it Dynamic' click that button and it will make your IP address dynamic.
4. Run the PR launcher and you should get an update.

It should be FIXED!
I'm sorry if it doesn't work for anyone else.


[R-COM]LITOralis.nMd 10-04-2013 06:11 PM

Re: Error 1301
 
Here is a test to see if it's a network issue:

Quote:

Originally Posted by Boris (Post 1950136)
Click this link to see what happens: http://prbf2.cdn.ancientdev.com/hashes_1.0.36.0.prhf

PRLauncher apparently resolves that hostname which points to a couple of IPV4/V6 addresses belonging to akamaitechnologies hosts that host the BF2PR file verification list for the particular version you're running.

If you click the link above your browser should throw up a "Save As" dialog or something asking you to download a "hashes_1.0.36.0.prhf" file. That file is just a PK zipped compressed file that can be decompressed to plain text using WinZip/WinRAR/7zip/etc, that contains a list of SHA1 hashes for the important PRBF2 game content.

I found that if PRLauncher cannot resolve the above hostname then you'll get the 1301 error returned.


[R-COM]LITOralis.nMd 10-04-2013 06:12 PM

Re: Error 1301
 
And one more thing, it could be an error in your .NET Framework ,


Quote:

Originally Posted by AttackRabbit (Post 1953281)
OK. I've got it working. The error had nothing to do with my network or port forwarding or connectivity or profiles or BF2 install or anything like that. I think it was just throwing 1301 because it was confused. Because I'm always deeply suspicious of .NET at all times, I ran Windows Updater and included some "optional" updates to the .NET 3.5 framework and also ran the .NET 4 repair tool. I ran the launcher and it worked fine! Verified the files, updated smoothly! Hopefully this will be helpful for others in the 1301 boat the 1301 error does not always mean a network problem

Cheers,

-Rabbit


ThatPieceOfGold 10-04-2013 06:47 PM

Re: Error 1301
 
I have tried all of these things and none of them have fixed the 1301 error do you have anything else?

[R-COM]LITOralis.nMd 10-04-2013 07:05 PM

Re: Error 1301
 
open prlauncher->click Support->Click Copy to CLipboard Button

Paste the text here so I can see your system specs.

ThatPieceOfGold 10-04-2013 07:34 PM

Re: Error 1301
 
Code:

System Information
------------------
  Operating System: Microsoft Windows 7 Home Premium  (6.1.7601)
      Architecture: 64-bit
          Language: English (United States)
      Motherboard: PEGATRON CORPORATION 2AC2
        Processor: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz (Physical: 4, Logical: 8)
            Memory: 8.00 GB
      DIMM Modules: XMM1: 4.00 GB @ 1333 MHz
                    XMM3: 4.00 GB @ 1333 MHz
        Page File: 7.98 GB
    .NET Framework: 4.5

Display Information
-------------------
 Display Device(s): HP 2711 Series Wide LCD Monitor on AMD Radeon HD 7700 Series
  Display Mode(s): 1920 x 1080 (32 bit) @ 60 Hz
    Driver Version: 9.12.0.0
    Display Memory: 1024.00 MB
    Multisampling: 2, 4, 8
              DPI: 96 (100%)

Audio Information
-----------------
  Primary Playback: Creative Labs Inc. Software
 Primary Recording: Microphone (Realtek High Defini
              EAX: True
          EAX 1.0: False
          EAX 2.0: True
          EAX 3.0: False
          EAX 4.0: False
          EAX 5.0: False
            X-RAM: False

Disk Information
----------------
      Install Path: C:\Program Files (x86)\Origin Games\Battlefield 2 Complete Collection
                    Free: 1.21 TB, Total: 1.80 TB, NTFS
          Mod Path: C:\Program Files (x86)\Origin Games\Battlefield 2 Complete Collection\mods\pr
                    Free: 1.21 TB, Total: 1.80 TB, NTFS
    Profiles Path: C:\Users\Joseph\Documents\ProjectReality\Profiles
                    Free: 1.21 TB, Total: 1.80 TB, NTFS
    Update DL Path: C:\Users\Joseph\AppData\Local\Project Reality\Project Reality BF2\Downloads
                    Free: 1.21 TB, Total: 1.80 TB, NTFS
  Update Log Path: C:\Users\Joseph\AppData\Local\Project Reality\Project Reality BF2\UpdateLogs
                    Free: 1.21 TB, Total: 1.80 TB, NTFS

Game Information
----------------
      CD Key Valid: True
    Installed Mods: bf2, pr, xpack
      Current Mod: pr
      BF2 Version: BF2 1.5
        PR Version: 1.0.29.0
          Language: english
  Debug Available: False
    Large Address: True
Supported Hardware: None

Profile Information
-------------------
      Profile 0001: ThatPieceOfGold
              Type: Online
        View Intro: True
        Fullscreen: True
      Display Mode: 1920x1080@60Hz
Display Mode Valid: True
  Graphics Scheme: Custom
    Multisampling: Off
            VSync: False
  Terrain Quality: High
  Effects Quality: High
  Geometry Quality: High
  Texture Quality: Low
  Lighting Quality: Low
  Dynamic Shadows: High
    Dynamic Lights: High
 Texture Filtering: High
    Audio Provider: Hardware
    Provider Valid: True
    Audio Quality: High
              EAX: True


[R-COM]LITOralis.nMd 10-04-2013 08:16 PM

Re: Error 1301
 
let's try this:

Quote:

Originally Posted by Boris (Post 1951476)
It's possible IPv6 is causing you problems there. Go to the network adapter you use to connect to the Internet, select "Properties", on the "Networking" tab untick "Internet Protocol Version 6 (TCP/IPv6)", OK it, then restart the machine. Run PR, and if it still fails, make another ProcMon log if you can and paste it here.


If that doesn't work, please follow the directions here:



Quote:

Originally Posted by Boris (Post 1951247)
K, so if the ticker's working then that should prove PRLauncher.exe has UDP/TCP outbound access fine enough.

If you could do the following it should prove helpful: Grab this Process Monitor application and extract/run it (it's free and clean - no need to install - no bs included).

On startup, set the "Filter" popup window to the following:

Process Name > is > PRLauncher.exe > then > Include > Add > OK

There are five icons top right on the main window when it opens that allow for toggling on/off what gets displayed; uncheck all except "Show Network Activity", then run PRLauncher and attempt to launch/update the game. ProcMon will produce an output that should indicate exactly what it's doing. The process goes something like the following:

Code:

Start PRLauncher;
-----------------
1. UDP domain lookup (ingame.realitymod.com)
2. TCP connect to 74.55.51.162:80 (ingame.realitymod.com) = ticker data
        On Error = "Error loading news..."

Launch game;
------------
3. UDP domain lookup (gpcm.gamespy.com)
4. TCP connect to 69.10.30.242:29900 (gpcm.gamespy.com) = user login
        On Error = "1004: Error connecting to server. (10061)"

5. UDP domain lookup (prbf2.cdn.ancientdev.com)
6. TCP connect to 63.236.252.179:80 (random akamai/other host) = verification list
        On Error = "1301: Unable to contact verification server. Please check your internet connection and try again."

If you could post the output from that then that'd be great. Just save the result out in plaintext CSV form and paste it here (you can open it in Notepad to copy it), or you could just screenshot it.

A little long-winded all this, but trying to drill down to the fault here. ;)


ThatPieceOfGold 10-04-2013 11:00 PM

Re: Error 1301
 
http://i.imgur.com/ARJgyGC.png


All times are GMT -4. The time now is 09:17 PM.

Powered by: vBulletin. ©vBulletin Solutions, Inc.
All Content Copyright ©2004 - 2015, Project Reality.


Search Engine Optimization by vBSEO 3.6.1